Questo forum utilizza i cookies
Questo forum fa uso di cookie per memorizzare le informazioni di login se sei registrato, e la tua ultima visita se non lo sei. I cookie sono brevi documenti di testo memorizzati sul tuo computer; i cookie impostati dal forum possono essere utilizzati solo su questo sito e senza rischi per la sicurezza. I cookie su questo forum possono anche monitorare gli argomenti specifici che hai letto e quando li hai letti. Si prega di confermare se si accettano o si rifiutano le impostazioni di questi cookie.

Un cookie viene memorizzato nel browser indipendentemente dalla scelta agita per evitare che sia ripetuta ancora una volta la domanda. Sarai in grado di modificare le impostazioni dei cookie in qualsiasi momento utilizzando il link a piè di pagina


[RISOLTO] Errore persistente all'apertura dei record creati con Sicurpass
#1
Ho il piacere e l'onere di essere il primo !

Grazie per l'opportunità offerta. Forse Sicurpass soffre di qualche difettuccio di gioventù. Sempre che non sbagli io.

Sto usando Sicurpass Free Portable 3.0.1. light con Win7 SP1 32 bit e la suite Comodo C.I.S. che integra un Firewall a regole, disabilitato per l'occasione. (Il firewall integrato in Windows 7 è disabilitato per default). Browser utilizzati per la prova: Google Chrome 16.0.912.75 m (Predefinito) - I.E. 9 v. 9.0.8112.16421 agg. 9.0.4 - Firefox 8.01 -

Ho creato ex-novo un nuovo gruppo "Forum", quindi ho cliccato sull'icona a forma di chiave con freccia verde verso il basso (nuova password) e ho inserito i dettagli di un sito, con l'identificativo, il nome utente e la password (sia criptata che non. Ho fatto più tentativi). Ho salvato, quindi il nuovo record risulta registrato. Come da immagine postata.
LINK1

Doppio click sul record e sia apre regolarmente il browser predefinito riportante nella barra degli indirizzi l'indirizzo così come salvato nel record di Sicurpass ed anche corretto sintatticamente, tuttavia il sito non si apre e il browser dà un errore visibile nell'immagine jpg postata.
LINK2

Se in questa situazione di errore - al di fuori di Sicurpass - tento di aprire una nuova istanza del browser utilizzando il medesimo browser cliccando direttamente sull'icona del collegamento sul desktop (o da qualsiasi altra posizione) ottengo il medesimo errore: non solo non si apre più alcun link! Se chiudo la finestra del brower con l'errore, aperta da Sicurpass, oppure termino Sicurpass l'errore non si ripete più. Se invece tento l'accesso ad una pagina web da un browser diverso da quello "attualmente bloccato" (diciamo così per spiegare) da Sicurpass, questo diverso browser apre la pagina web.

Nel caso in cui - invece - il browser è precedentemente aperto a qualsiasi indirizzo, ancor prima di cliccare sul record di Sicurpass - il record creato con sicurpass funziona : cliccandoci sopra finalmente si apre la pagina creata memorizzata assieme alla relativa password.

E' stato impegnativo da spiegare e forse lo sapete già, spero che il bug verrà risolto. Cordiali saluti.
#2
Ciao, grazie per essere intervenuto!
Nel leggere la tua domanda, molto ben formulata e con dovizia di particolari, ci siamo immediatamente attivati alfine di controllare se, effettivamente, la procedura da te formulata possa rappresentare un baco. Hanno partecipato ai test, oltre lo scrivente, Pierluigi e Daniel. Abbiamo utilizzato Windows XP, Vista e Seven su computer di tipo desktop e laptop (portatili). Daniel ha utilizzato una configurazione identica a quella da te descritta, quindi con le medesime caratteristiche, testando Sicurpas con Explorer, Mozilla e Google Chrome. Altrettanto abbiamo fatto Pierluigi ed io su portatili Toshiba, Compaq, HP, Sony Vaio. Il risultato dei test ha dimostrato la perfetta funzionalità di Sicurpas nella procedura da te descritta e da noi seguita passo passo. Non abbiamo riscontrato l'errore da te descritto.
Prova a testare Sicurpas su altre macchine per vedere che non possano magari esservi problemi nel tuo sistema. Per quanto riguarda la versione portable Sicurpas non interagisce in modo alcuno col sistema o col registro, a meno che, nella pagina delle opzioni, tu non decida di associare l'icona del programma ai file cifrati o alle schede. Questa operazione scrive due stringhe nel registro che sono totalmente innocue e possono essere rimosse in qualsivoglia momento. Ti descrivo a seguire l'istruzione utilizzata dal programma per aprire un sito internet:

ShellExecute(0, nil, Pchar(Lv_pas.Selected.SubItems[1]), nil, nil, 0);

Questa istruzione è totalmente innocua e non in grado di cagionare gli errori da te descritti, non solo, funziona praticamente in ogni circostanza.
Siamo a tua completa disposizione per ulteriori chiarimenti. Grazie ancora per la tua partecipazione.
Ti salutano cordialmente Pierluigi, Daniel e Mariano.


#3
Prima di utilizzare il vecchio XP SP3 ad avvio multiboot su partizione separata per testare il programma come consigliato, ho fatto un nuovo tentativo da Seven di cui purtroppo non posso postare le schermate, perchè ora sono su XP...

Dopo aver creato una nuova password (sempre di http://www.sicurpas.it/forum) ho tentato di salvare la scheda. Procedura assolutamente normale prevista e prevedibile: si è prodotto un errore strano: ho ricevuto un diniego per errore di scrittura su C:\windows\system\temp\nomefile"nonricordo".boh. (il nome del file è inventato!). La cartella temp - com'è noto - è soggetta e quindi abilitata alla scrittura di files di vario tipo, nonché temporanei da vari processi, installazioni, aggiornamenti ecc.

Ho controllato la coerenza dei permessi di system e di system\temp con altre cartelle di sistema e li ho trovati identici e come ci si dovrebbe attendere: system, creator owner, administrators, user. La stessa cosa dicasi per i permessi specifici attribuiti a ciascun utente: anche questi sono come ci si aspetta, System e Administrators, controllo completo, User, lettura e scrittura ecc. Il proprietario del disco C sono io ed ho effettuato accesso con privilegi amministrativi. Il firewall e la protezione pro-attiva sono disabilitate per l'evenienza.

Errori di questo genere non si sono mai verificati con altri software. In seguito a questo errore la schermata di sicurpas freeware3.0. light si è bloccata del tutto. Per chiuderla ho dovuto usare ctrl-alt-shift e terminare il processo.

Dopo essere uscito da Seven e rientrato dopo una "passeggiata" su XP descritta sotto, sono rientrato su Seven ed ho tentato un nuovo salvataggio. Questa volta la procedura ha avuto successo !! Non so cosa pensare . . .

#######

Ora su Xp 32bit SP3 dopo aver lanciato Sicurpas, aver creato una nuova scheda, creato il sottogruppo Forum, quindi la chiave per il Forum di Sicurpas, ho lasciato Sicurpas inattivo durante la stesura di queste righe.

Dopo tre minuti circa, la scheda creata (ma non ancora salvata) si è chiusa da sola, ed il programma si è presentato vuoto di schede come se fosse stato lanciato per la prima volta. Ricomincio da capo....

Ho ricreato la stessa scheda (al momento non lo ancora salvata) "http://www.sicurpas.it/forum/" con Identificativo, nomeutente e password: ora se clicco sul record, o meglio sulla password, questa volta la pagina di accesso al forum finalmente si apre, ma i campi nomeutente e password sono ancora da compilare.

Ho creato una seconda password in questo caso del link diretto a questa stessa pagina in cui sto scrivendo e quindi con accesso già effettuato: http://www.sicurpas.it/forum/showthread.php?tid=161 Mi sono disconnesso. Ho cliccato sul questo record, o meglio sulla password relativa alla pagina http://www.sicurpas.it/forum/showthread.php?tid=161 e mi sono ritrovato nella vostra schermata di login.

Ho creato una terza chiave ad un link ad accesso consentito solo dopo aver effettuato il login: anche in questo caso, mi si presenta la solita griglia di login con richiesta di inserimento di login e password:
http://imageshack.us/photo/my-images/15/...nejkj.png/ - http://imageshack.us/photo/my-images/651...inecw.png/

Credevo di aver capito che il record salvato con la relativa password mi permettesse l'accesso DIRETTO a pagine protette di un sito senza dover digitare la password, peraltro salvata ed archiviata. Ma forse non ho capito bene.

Sono dispiaciuto, perché avevo delle attese su questo sw certamente non per l'uso di forum ma per attività che richiedono una certa sicurezza e stabilità. Nelle intenzioni è un prodotto estremamente utile. Ma i problemi incontrati per ora non mi consentono di usare il software con semplicità e scioltezza come dovrebbe essere. Sempre che il problema non sia io

Ho messo in ogni caso risolto nel primo msg

Cordialmente . . .

Jamal K
#4
Ciao, grazie per essere intervenuto,
l’apporto degli utenti per il buon funzionamento di un software è assolutamente indispensabile, pertanto tutte le segnalazioni volte a palesare eventuali errori sono benedette come manna dal cielo. Come tutti i software anche Sicurpas indubitabilmente conterrà dei bachi e noi siamo qui per porvi rimedio. Senza mettere in dubbio le tue esternazioni, debbo dirti che, seguendo esattamente la strada da te indicata Sicurpas non ha evidenziato i problemi che tu descrivi. E’ possibile che a noi sia sfuggita qualcosa, però la creazione e memorizzazione di una scheda avviene senza alcun problema. Il dispositivo di sicurezza che chiude la scheda entra in funzione solamente con delle schede già archiviate, pertanto, ripetendo dei test anche su quanto da te suggerito in merito, il programma ha sempre risposto nel modo corretto. Per quanto riguarda la certificazione automatica all’interno dei siti internet, ti assicuro che Sicurpas ingloba questo modulo già dalla versione 3.0. Semplicemente abbiamo preferito non abilitarlo per questioni legate alla sicurezza. La certificazione automatica, come ben saprai, comporta la simulazione della tastiera, quindi l’inevitabile contatto con programmi di tipo Keylogger. Ciò implica che, se il sistema non è più che blindato, si rischia di consegnare le proprie password a questo tipo di programmi. Abbiamo preferito, in attesa di completare il nostro sistema anti keylogger di dotare il programma con una tecnica di trascinamento che prevede la decodifica della password esclusivamente al momento in cui questa viene rilasciata all’interno di una procedura di certificazione. Se provi, con la versione da te in utilizzo, a trascinare username e password in un sito ti accorgerai che il meccanismo, oltre che semplicissimo, è ad altissima sicurezza. Esegui un test con dei programmi di tipo memory dump e poi ci saprai dire.
Concludo esortandoti cortesemente a testare nuovamente Sicurpas in altri ambienti software differenti dal tuo ed osservare se i problemi da te descritti abbiano a presentarsi nuovamente. Mi spiace di questa situazione, ti garantisco che il programma viene utilizzato da tantissimi utenti con grande soddisfazione, soprattutto per il livello di sicurezza che Sicurpas offre. Ad ogni modo, nel ringraziarti per questo tuo preziosissimo contributo, ti garantisco che continueremo ad effettuare i test in base ai tuoi suggerimenti e, qualora in effetti si dovesse palesare qualche malfunzionamento, correremo immediatamente ai ripari e renderemo pubblico sul forum il risultato acquisito. Grazie ancora per il tuo interessamento.
Siamo a tua completa disposizione per eventuali chiarimenti.
Un caro saluto dalla terra dei nuraghi.
#5
Intervengo nella discussione perchè ho avuto modo di scaricare ed utilizzare Sicurpas versione portable.
Tutte le prove citate in questa discussione sono state da me personalmente eseguite ed il programma ha funzionato correttamente.
Sicurpas per me è un ottimo programma!




Vai al forum:


Utente(i) che stanno guardando questa discussione: 1 Ospite(i)